PHP is amongst the most commonly used object-oriented programming languages. It is exceptionally popular because it is free software, which you can use to set up interactive sites such as social networking websites, web stores or e-teaching portals instead of static HTML websites. A PHP module must be activated on the web server where a PHP-driven website is hosted so that its source code can be ‘decrypted’. Because there aren’t any license fees for such a module and the language provides countless options for the apps that you set up, there’re 100s of millions of PHP-powered sites. What’s more, there’re a myriad of PHP-based scripts, which you can use for your sites without having to possess any programming experience. Considering the fact that there are a handful of PHP versions, you need to confirm whether the exact same version that you used whilst setting up your website is available on the web server too.
PHP 4 and PHP 5 Support in Hosting
In case you get a hosting plan from us, you will never need to ask yourself whether or not your sites are compatible with the hosting platform, since multiple versions of PHP are activated on our servers for your convenience’s sake. The Hepsia Control Panel will allow you to pick PHP 5.5, 5.4, 5.3, 5.2 or 4 with just one click of the mouse and if you wish to change the current version, the update will take effect momentarily. Thus, several years of work on sites built with an older PHP version will not be in vain. Our web hosting platform will even permit you to use a different PHP version for each domain hosted in your account, so you can run older and newer scripts at the same time. Most hosting companies on the marketplace support one, sometimes two versions of PHP. In contrast to them, we reckon that you should be the one to pick the version that your own sites will be using.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
Our semi-dedicated plans support multiple PHP versions, so you will be able to use all the Internet apps that you have created over the years. The Hepsia Control Panel, which comes with each semi-dedicated server account, will enable you to enable the required version with a single click. You can pick between PHP 5.5, 5.4, 5.3, 5.2 and 4. If you’d like to host multiple sites under one account and they have distinct requirements as regards the hosting environment, you’ll be able to pick a different version for each one of them no matter which version is enabled for the account itself. That’s accomplishable thanks to our in-house created cloud platform, which allows us to run multiple PHP versions concurrently. In stark comparison, the vast majority of web hosts normally support one, in extremely rare cases – two versions.